xpra icon
Bug tracker and wiki

Version 18 (modified by Antoine Martin, 4 years ago) (diff)

--

http://xpra.org/icons/packages.png

Dependencies

Most of these dependencies should be installed automatically when you install packages.

Project Source Download Link Purpose Client or Server Required Notes
gtkhttp://ftp.gnome.org/pub/gnome/sources/gtk+/UI Toolkitbothhttp://xpra.org/icons/ticked-small.pngVersion 2.x only for server, version 3.x not fully supported by the client (#640)
numpyhttp://sourceforge.net/projects/numpy/files/NumPy/Python Buffersboth
pyopenglhttps://pypi.python.org/pypi/PyOpenGL and
https://pypi.python.org/pypi/PyOpenGL-accelerate
OpenGL accelerated renderingclient
Network:
python-lz4https://github.com/steeve/python-lz4lz4 packet compressionbothrecommended
lzohttp://www.oberhumer.com/opensource/lzo/download/lzo packet compressionboth
http://pycrypto.orgpycryptoEncryptionboth
python-netifaceshttps://pypi.python.org/pypi/netifaces]Multicast DNS session publishingserver
Picture encoding dependencies:
x264ftp://ftp.videolan.org/pub/x264/snapshots/h264 encodingserver
ffmpeghttp://ffmpeg.org/releases/h264, h265, vp8 and vp9 decodingclient
vpxhttp://downloads.webmproject.org/releases/webm/index.htmlvp8 and vp9 codecboth
webphttp://downloads.webmproject.org/releases/webp/index.htmlwebp codecboth
python-pillowhttps://pypi.python.org/pypi/Pillowpng,jpeg,webp encoding and decoding, format conversionbothhttp://xpra.org/icons/ticked-small.png
Sound dependencies:
Ogghttp://downloads.xiph.org/releases/ogg/ogg container formatboth
Flachttp://downloads.xiph.org/releases/flac/flac codecboth
Speexhttp://downloads.xiph.org/releases/speex/speex codecboth
Vorbishttp://downloads.xiph.org/releases/vorbis/vorbis codecboth
wavpackhttp://www.wavpack.com/downloads.htmlwavpack codecboth
lamehttp://sourceforge.net/projects/lame/files/lame/MP3 codecboth
TwoLamehttp://sourceforge.net/projects/twolame/files/twolame/MP3 encodingboth
Madhttp://sourceforge.net/projects/mad/files/libmad/MP3 decodingboth
gstreamerhttp://gstreamer.freedesktop.org/src/sound supportboth
Build dependencies:
cythonhttp://cython.org/release/Cython compiler

http://xpra.org/icons/win32.png

MS Windows

The dependencies specific to MS Windows are only required when building from source. The original reference documentation comes from winswitch: http://winswitch.org/dev/win32.html.

Project Source Download Link Purpose Current Version Used
(Available)
pywin32http://sourceforge.net/projects/pywin32/files/pywin32/Native win32 API219
python-wmihttps://pypi.python.org/pypi/WMI/#downloadsWMI API1.4.9
puttyhttp://tortoisesvn.net/downloads.htmlSSH transport1.8.11.26392 (see note below)
py2exehttp://sourceforge.net/projects/py2exe/files/py2exe/create standalone executable0.6.9
InnoSetuphttp://www.jrsoftware.org/isdl.phpcreate installer package5.5.6

About putty: we use the tortoisesvn build which includes a better UI, but version 1.9 is no longer compatible with Windows XP.

http://xpra.org/icons/osx.png

Mac OS X

The dependencies specific to Mac OS X are only required when building from source. The original reference documentation comes from winswitch: http://winswitch.org/dev/macosx-manual.html. Most of these dependencies are build tools and libraries which are not available by default with Apple's the developer tools.

Project Source Download Link Current Version Used
(Available)
yasmhttp://www.tortall.net/projects/yasm/releases/1.3.0
http://www.nasm.us/http://www.nasm.us/pub/nasm/releasebuilds/2.11.08
ORChttp://gstreamer.freedesktop.org/src/orc/0.4.22 (0.4.24)

Currently out of date in the moduleset:

  • ffmpeg
  • cython
  • pillow