xpra icon
Bug tracker and wiki

Changes between Version 7 and Version 8 of Packaging/DistributionPackages


Ignore:
Timestamp:
01/17/20 07:17:10 (6 weeks ago)
Author:
Antoine Martin
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Packaging/DistributionPackages

    v7 v8  
    55And why you should generally not use them.
    66
     7A great explanation of the Debian / Ubuntu packaging mess can be found here: [https://mjg59.dreamwidth.org/41085.html ​Matthew Garrett: There's more than one way to exploit the commons].
     8
     9Debian's hand waving about backports is rightfully ignored here.
     10
    711The list of currently supported versions can be found here: [/wiki/Versions].
     12
     13----
     14
     15This table was generated on the '''2020-01-17''' when {{{3.0.5}}} was the latest LTS version available.
     16
     17||=Distribution=||=Variant=||=Version Shipped=||=Known Issues=||
     18||Fedora||[https://getfedora.org/ Fedora 30 and 31]||[https://admin.fedoraproject.org/updates/xpra 3.0.3]||OK: 3.0.5 in testing, you may want to add [http://rpmfusion.org/ rpmfusion]'s xpra-codecs-freeworld package to get all the codecs - only one problem: their packaging unmercifully conflict with the packages from xpra.org||
     19||Ubuntu||[http://releases.ubuntu.com/16.04/ Xenial aka 16.04]||[http://packages.ubuntu.com/xenial/xpra 0.15.8]||over 4 years without any fixes, known bugs and security vulnerabilities - '''do not use''', '''very dangerous''', missing components, etc||
     20||Ubuntu||[http://releases.ubuntu.com/18.04/ Bionic aka 18.04]||[http://packages.ubuntu.com/bionic/xpra 2.1.3]||2.5 years without any fixes, numerous serious issues, '''dangerous''' ||
     21||Ubuntu||[http://releases.ubuntu.com/19.10/ Eoan aka 19.10]||[https://launchpad.net/ubuntu/eoan/+package/xpra 2.4.3]||buggy, 14 months without any fixes||
     22||Debian||[https://www.debian.org/releases/buster/ Buster]||[https://packages.debian.org/buster/xpra 2.4.3]||buggy, 14 months without any fixes ||
     23||Debian||[https://www.debian.org/releases/stretch/ Stretch]||[https://packages.debian.org/stretch/xpra 0.17.6]||3.5 years out of date, known bugs and security vulnerabilities - '''do not use''', '''very dangerous''', missing components, etc||
     24||Gentoo||[http://www.gentoo.org/ Stable] ||[http://packages.gentoo.org/package/x11-wm/xpra 2.2.2]||Dire: 2 years out of date! ||
     25||Gentoo||[http://www.gentoo.org/ Testing] ||[http://packages.gentoo.org/package/x11-wm/xpra 3.0.2]||Missing some important fixes, dubious patches applied||
     26||||[https://www.archlinux.org/ Arch] ||[https://www.archlinux.org/packages/community/x86_64/xpra/ 3.0.5]||Great: fully up to date ||
     27
     28
     29To see the fixes that are missing, follow the "Commit log" links for each branch on the "Release Notes" section of the [/Versions/PendingFixes version / fixes page].
    830
    931
    1032----
    11 
    1233
    1334
     
    1637||=Distribution=||=Variant=||=Version Shipped=||=Known Issues=||
    1738||Fedora||[https://getfedora.org/ Fedora 24 and 25]||[https://admin.fedoraproject.org/updates/xpra 1.0]||missing critical updates, you may want to add [http://rpmfusion.org/ rpmfusion]'s xpra-codecs-freeworld package to get all the codecs||
    18 ||Ubuntu||[http://releases.ubuntu.com/14.04/ Trusty aka 14.04]||[http://packages.ubuntu.com/trusty/xpra 0.12.3]||not a single fix applied in 3 years, '''dangerous''' ||
     39||Ubuntu||[http://releases.ubuntu.com/14.04/ Trusty aka 14.04]||{{{http://packages.ubuntu.com/trusty/xpra}}} (link is now 404) 0.12.3||not a single fix applied in 3 years, '''dangerous''' ||
    1940||Ubuntu||[http://releases.ubuntu.com/16.04/ Xenial aka 16.04]||[http://packages.ubuntu.com/xenial/xpra 0.15.8]||16 months without any fixes, based on a dead branch ||
    2041||Debian||[https://www.debian.org/releases/jessie/ Jessie]||[https://packages.debian.org/jessie/xpra 0.14.10]||Awful: 2.5 years and 27 stable updates missing! [[BR]] Version no longer supported, includes known bugs, crashes and serious security vulnerabilities - '''dangerous'''! ||
    21 ||Debian||[https://www.debian.org/releases/jessie/ Jessie-backports]||[https://packages.debian.org/jessie-backports/xpra 0.17.6]||Backports an EOL version!? ||
    22 ||Debian||[https://www.debian.org/releases/stretch/ Stretch]||[https://packages.debian.org/stretch/xpra 0.17.6]||EOL version, known bugs and security vulnerabilities - '''do not use'''||
     42||Debian||[https://www.debian.org/releases/jessie/ Jessie-backports]||{{{https://packages.debian.org/jessie-backports/xpra}}} (link is now 404) 0.17.6]||Backports an EOL version!? ||
     43||Debian||[https://www.debian.org/releases/stretch/ Stretch]||[https://packages.debian.org/stretch/xpra 0.17.6||EOL version, known bugs and security vulnerabilities - '''do not use'''||
    2344||Gentoo||[http://www.gentoo.org/ Stable] ||[http://packages.gentoo.org/package/x11-wm/xpra 1.0.3]||Not too bad: 1 minor update behind||
    2445||Gentoo||[http://www.gentoo.org/ Testing] ||[http://packages.gentoo.org/package/x11-wm/xpra 1.0.4]||Good: up to date! ||
    25 ||||[https://www.archlinux.org/ Arch] ||[https://aur.archlinux.org/packages/xpra-winswitch/ 2.0]||Great: most up to date ||
    26 
    27 
    28 To see the fixes that are missing, follow the "Commit log" links for each branch on the "Release Notes" section of the [/Versions/PendingFixes version / fixes page].
    29 
    30 A great explanation of the Debian / Ubuntu packaging mess can be found here: [https://mjg59.dreamwidth.org/41085.html ​Matthew Garrett: There's more than one way to exploit the commons].
     46||||[https://www.archlinux.org/ Arch] ||{{{https://aur.archlinux.org/packages/xpra-winswitch}}} (link is now 404) 2.0||Great: most up to date ||
    3147
    3248
    3349----
    3450
    35 Here's an older version of this table, last updated '''2015-12-28''', when 0.15.10 was the latest version available. (0.14.33 for LTS branch).
     51Here's an even older version of this table, last updated '''2015-12-28''', when 0.15.10 was the latest version available. (0.14.33 for LTS branch).
    3652
    3753
    3854||=Distribution=||=Variant=||=Version Shipped=||=Known Issues=||
    3955||Fedora||[https://getfedora.org/ Fedora 21 and 22]||[https://admin.fedoraproject.org/updates/xpra 0.15.9]||Up to date (0.15.10 in "testing" queue), but you need [http://rpmfusion.org/ rpmfusion]'s xpra-codecs-freeworld package to get all the codecs||
    40 ||Ubuntu||[http://releases.ubuntu.com/12.04/ Precise aka 12.04]||[http://packages.ubuntu.com/precise/xpra 0.0.7.36]||Far too many to list - not a single bug fix applied in 4 years! ||
    41 ||Ubuntu||[http://releases.ubuntu.com/14.04/ Trusty aka 13.04]||[http://packages.ubuntu.com/trusty/xpra 0.12.3]||Far too many to list - not a single bug fix applied in 2 years, avoid||
    42 ||Ubuntu||[http://releases.ubuntu.com/15.04/ Vivid aka 15.04]||[http://packages.ubuntu.com/vivid/xpra 0.14.10]||Awful: 23 stable updates missing! version no longer supported, known bugs including crashes and vulnerabilities - avoid! ||
    43 ||Debian||[https://www.debian.org/releases/squeeze/ Squeeze Backports]||[https://packages.debian.org/squeeze-backports/xpra 0.3.11]||Fundamentally broken - do not use||
    44 ||Debian||[https://www.debian.org/releases/wheezy/ Wheezy]||[https://packages.debian.org/wheezy/xpra 0.3.11]||Fundamentally broken - do not use||
    45 ||Debian||[https://www.debian.org/releases/wheezy/ Wheezy-backports]||[https://packages.debian.org/wheezy-backports/xpra 0.14.10]||Awful: 23 stable updates missing! version no longer supported, known bugs including crashes and vulnerabilities - avoid! ||
    46 ||Debian||[https://www.debian.org/releases/jessie/ Jessie]||[https://packages.debian.org/jessie/xpra 0.14.10]||Awful: 23 stable updates missing! version no longer supported, known bugs including crashes and vulnerabilities - avoid! ||
    47 ||Debian||[https://www.debian.org/releases/jessie/ Jessie-backports]||[https://packages.debian.org/jessie-backports/xpra 0.16.3]||Not too bad.||
     56||Ubuntu||[http://releases.ubuntu.com/12.04/ Precise aka 12.04]||{{{http://packages.ubuntu.com/precise/xpra}}} (link is now 404) 0.0.7.36||Far too many to list - not a single bug fix applied in 4 years! ||
     57||Ubuntu||[http://releases.ubuntu.com/14.04/ Trusty aka 13.04]||[{{{http://packages.ubuntu.com/trusty/xpra}}} (link is now 404) 0.12.3||Far too many to list - not a single bug fix applied in 2 years, avoid||
     58||Ubuntu||[http://releases.ubuntu.com/15.04/ Vivid aka 15.04]||[{{{http://packages.ubuntu.com/vivid/xpra}}} (link is now 404) 0.14.10||Awful: 23 stable updates missing! version no longer supported, known bugs including crashes and vulnerabilities - avoid! ||
     59||Debian||[https://www.debian.org/releases/squeeze/ Squeeze Backports]||{{{https://packages.debian.org/squeeze-backports/xpra}}} (link is now 404) 0.3.11||Fundamentally broken - do not use||
     60||Debian||[https://www.debian.org/releases/wheezy/ Wheezy]||{{{https://packages.debian.org/wheezy/xpra}}}} (link is now 404) 0.3.11||Fundamentally broken - do not use||
     61||Debian||[https://www.debian.org/releases/wheezy/ Wheezy-backports]||{{{https://packages.debian.org/wheezy-backports/xpra}}} (link is now 404) 0.14.10||Awful: 23 stable updates missing! version no longer supported, known bugs including crashes and vulnerabilities - avoid! ||
     62||Debian||[https://www.debian.org/releases/jessie/ Jessie]||{{{https://packages.debian.org/jessie/xpra}}} (link is now 404) 0.14.10||Awful: 23 stable updates missing! version no longer supported, known bugs including crashes and vulnerabilities - avoid! ||
     63||Debian||[https://www.debian.org/releases/jessie/ Jessie-backports]||{{{https://packages.debian.org/jessie-backports/xpra}}} (link is now 404) 0.16.3||Not too bad.||
    4864||Gentoo||[http://www.gentoo.org/ Stable] ||[http://packages.gentoo.org/package/x11-wm/xpra 0.15.6]||Not too bad: 4 minor updates behind||
    4965||Gentoo||[http://www.gentoo.org/ Testing] ||[http://packages.gentoo.org/package/x11-wm/xpra 0.15.9]||Good: only one minor update behind||
    5066||||[https://www.archlinux.org/ Arch] ||[https://aur.archlinux.org/packages/xpra-winswitch/ 0.15.9]||Good: only one minor update behind||
    51 
    52 Omitted:
    53 * because not available with a default installation: Debian experimental.
    54 * opensuse: [http://software.opensuse.org/package/xpra no packages available]
    55 
    5667
    5768----