xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Custom Query (2683 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (34 - 36 of 2683)

2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
Ticket Resolution Summary Owner Reporter
#2945 invalid Xpra stopped working after Ubuntu update Antoine Martin wanderyr
Description

I have had a working installation of v4.0.4-r27557 on Kubuntu 20.04. I just ran apt-get update then apt-get upgrade and now xpra doesn't start correctly. I'm not sure which of the changes might have broken it. I ran the update on Nov 18, 2020. The previous update was, perhaps, five weeks ago.

I've purged xpra and reinstalled it, with the same results. (sudo apt-get purge xpra, then sudo apt-get install xpra)

After the failure, there is a running xpra process but it doesn't work:

$ ps aux | grep xpra
{username}         5577  0.0  1.1 934796 158736 ?       SLl  03:43   0:00 /usr/bin/python3 /usr/bin/xpra start --start=xterm

$ xpra list
No xpra sessions found

Please let me know any additional information that would help. Thank you very much for your time.

$ xpra start --start=xterm
2020-11-18 03:43:29,037 Warning: failed to create script directory '/run/user/1000/xpra':
2020-11-18 03:43:29,037  [Errno 2] No such file or directory: '/run/user/1000/xpra'
2020-11-18 03:43:29,037  ($XDG_RUNTIME_DIR has not been created?)
jon@mighty-mitx:~/.config/xpra$ Entering daemon mode; any further errors will be reported to:
  /tmp/S5564.log
Actual display used: :1
Actual log file name is now: /tmp/:1.log

$ cat /tmp/:1.log
2020-11-18 03:43:29,091 cannot access python uinput module:
2020-11-18 03:43:29,091  No module named 'uinput'
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
2020-11-18 03:43:30,271 Warning: failed to create socket directory '/run/user/1000/xpra'
2020-11-18 03:43:30,271  [Errno 2] No such file or directory: '/run/user/1000/xpra'
2020-11-18 03:43:30,272 Warning: cannot create socket '/run/user/1000/xpra/mighty-mitx-1':
2020-11-18 03:43:30,272  [Errno 2] No such file or directory
2020-11-18 03:43:30,272  ($XDG_RUNTIME_DIR has not been created?)
2020-11-18 03:43:30,272 cannot create group socket '/run/xpra/mighty-mitx-1'
2020-11-18 03:43:30,272  [Errno 13] Permission denied
2020-11-18 03:43:30,272 Warning: no local server sockets,
2020-11-18 03:43:30,272  forward-xdg-open cannot be enabled
2020-11-18 03:43:30,272  non-embedded ssh connections will not be available
2020-11-18 03:43:30,310 pointer device emulation using XTest
2020-11-18 03:43:30,684 serving html content from '/usr/share/xpra/www'
2020-11-18 03:43:30,693 Warning: no local sockets defined,
2020-11-18 03:43:30,693  disabling printer forwarding
2020-11-18 03:43:30,708 D-Bus notification forwarding is available
2020-11-18 03:43:30,713 Warning: the runtime directory '%s' does not exist,
2020-11-18 03:43:30,713  cannot start a private pulseaudio server
2020-11-18 03:43:30,717 pulseaudio server started with pid 5604
W: [pulseaudio] pid.c: Stale PID file, overwriting.
2020-11-18 03:43:30,968 GStreamer version 1.16.2 for Python 3.8.5 64-bit

(Xpra:5577): Gtk-CRITICAL **: 03:43:31.019: gtk_widget_realize: assertion 'widget->priv->anchored || GTK_IS_INVISIBLE (widget)' failed
2020-11-18 03:43:31,025 Warning: webcam forwarding is disabled
2020-11-18 03:43:31,025  the virtual video directory '/sys/devices/virtual/video4linux' was not found
2020-11-18 03:43:31,025  make sure that the 'v4l2loopback' kernel module is installed and loaded
2020-11-18 03:43:31,026 found 0 virtual video devices for webcam forwarding
2020-11-18 03:43:31,031 Warning: cannot watch for application menu changes without pyinotify:
2020-11-18 03:43:31,031  No module named 'pyinotify'
2020-11-18 03:43:31,054 Error parsing xdg menu data:
2020-11-18 03:43:31,054  ParsingError in file '/etc/xdg/menus/kde-debian-menu.menu', File not found
2020-11-18 03:43:31,054  this is either a bug in python-xdg,
2020-11-18 03:43:31,054  or an invalid system menu configuration
2020-11-18 03:43:31,192 xpra is ready.
2020-11-18 03:43:31,193 xpra GTK3 X11 version 4.0.4-r27557 64-bit
2020-11-18 03:43:31,294 13.7GB of system memory
2020-11-18 03:43:31,331  uid=1000 (jon), gid=1000 (jon)
2020-11-18 03:43:31,331  running with pid 5577 on Linux Ubuntu 20.04 focal
2020-11-18 03:43:31,331  connected to X11 display :1 with 24 bit colors
2020-11-18 03:43:32,209 OpenGL is supported on display ':1'
2020-11-18 03:43:32,209  using 'llvmpipe (LLVM 10.0.0, 128 bits)' renderer
Connection failure: Connection refused
pa_context_connect() failed: Connection refused
Connection failure: Connection refused
pa_context_connect() failed: Connection refused
#2941 duplicate xpra seamless client crash in SublimeMerge right-click crash stdedos stdedos
Description

Doing a right-click in Sublime Merge just crashed

"Xpra-Python3-x86_64_4.1-r27892\xpra_cmd" attach ssh://user@ip/3 --ssh="plink -ssh -agent" --modal-windows=no --title="@title@ on @@/@server-display@" --headerbar=off --opengl=no --bandwidth-limit=6Mbps

XPRA_CUSTOM_TITLE_BAR=0
XPRA_EXECUTABLE=Xpra-Python3-x86_64_4.1-r27892
XPRA_REPAINT_ALL=1
XPRA_SCROLL_ENCODING=0

2020-11-16 11:05:03,035 Xpra GTK3 client version 4.1-r27892 64-bit
2020-11-16 11:05:03,038  running on Microsoft Windows 10
2020-11-16 11:05:06,172 GStreamer version 1.18.1 for Python 3.8.6 64-bit
2020-11-16 11:05:07,350 created named pipe 'Xpra\15596'
2020-11-16 11:05:08,196 keyboard layout code 0x409
2020-11-16 11:05:08,198 identified as 'United States - English' : us
2020-11-16 11:05:09,045  keyboard settings: layout=us
2020-11-16 11:05:09,049  desktop size is 4160x1440 with 1 screen:
2020-11-16 11:05:09,049   Default (1100x381 mm - DPI: 96x96) workarea: 4160x1400
2020-11-16 11:05:09,050     Generic PnP Monitor 1600x900 at 0x534 (309x174 mm - DPI: 131x131) workarea: 1600x860 at 0x534
2020-11-16 11:05:09,050     C32JG5x 2560x1440 at 1600x0 (697x392 mm - DPI: 93x93) workarea: 2560x1400 at 1600x0
2020-11-16 11:05:15,652 enabled remote logging
2020-11-16 11:05:15,654 Xpra GTK3 X11 server version 3.0.12-r27620 64-bit
2020-11-16 11:05:15,654  running on Linux Ubuntu 16.04 xenial
2020-11-16 11:05:15,664 Attached to ip:22
2020-11-16 11:05:15,666  (press Control-C to detach)


(xpra_cmd:15596): Pango-WARNING **: 11:05:16.268: couldn't load font "Bitstream Vera Sans Not-Rotated 14.662109375", falling back to "Sans Not-Rotated 14.662109375", expect ugly output.
2020-11-16 11:05:17,314 UI thread is now blocked
2020-11-16 11:05:18,220 UI thread is running again, resuming
2020-11-16 11:07:26,246 Warning: failed to set clipboard data
2020-11-16 11:07:26,258  OpenClipboard: too many failed attempts, giving up
2020-11-16 11:08:25,251 Warning: failed to set clipboard data
2020-11-16 11:08:25,254  OpenClipboard: too many failed attempts, giving up
2020-11-16 11:10:02,432 UI thread is now blocked
2020-11-16 11:10:02,506 UI thread is running again, resuming
2020-11-16 11:10:47,072 Warning: failed to set clipboard data
2020-11-16 11:10:47,076  OpenClipboard: too many failed attempts, giving up
2020-11-16 13:45:52,267 Error: failed to set tray icon
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/platform/win32/win32_NotifyIcon.py", line 177, in make_ICONINFO
OSError: [WinError 87] The parameter is incorrect.
2020-11-16 13:45:53,271 Error: failed to set tray icon

[......]

2020-11-16 13:59:58,719 Error: failed to set tray icon
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/platform/win32/win32_NotifyIcon.py", line 167, in make_ICONINFO
  File "E:\Xpra\trunk\src/xpra/platform/win32/win32_NotifyIcon.py", line 212, in rgb_to_bitmap
OSError: [WinError 87] The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The operation completed successfully.

(xpra_cmd:15596): Gdk-CRITICAL **: 13:59:58.853: gdk_pixbuf_get_from_surface: assertion 'width > 0 && height > 0' failed

(xpra_cmd:15596): Gdk-CRITICAL **: 13:59:58.864: _gdk_win32_display_get_cursor_for_surface: assertion 'GDK_IS_PIXBUF (pixbuf)' failed
2020-11-16 13:59:58,882 error creating cursor: constructor returned NULL (using default)
Traceback (most recent call last):
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_base.py", line 828, in set_windows_cursor
  File "E:\Xpra\trunk\src/xpra/client/gtk_base/gtk_client_base.py", line 953, in make_cursor
TypeError: constructor returned NULL
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
_create_dc_and_bitmap: The parameter is incorrect.
2020-11-16 14:00:00,535 UI thread is now blocked


However, the log is 330k long - I will just attach it, along with the server's one.

I also have two xpra cores (1.1G and 600M) and obviously I cannot upload them. Let me know if you need them.

#2940 duplicate How to register screen in background? Antoine Martin Francesco Potortì
Description

I have a task for which I think I could use Xpra, but I cannot manage it. I sometimes follow a webinar which is streamed in real time. I would like to have a sort of timeshift. In order to do that, I think I could:

  • launch a local Xpra server on, say :7
  • launch a browser on :7 running a web video
  • launch ffmpeg on :7 and grab the video to disk

Now I should be able to timeshift the video by playing the one recorded on disk, while it is recorded

However, it does not work and I do not know why. Here is what I did. the resulting video shows a white window and sound coming from the microphone. What am I doing wrong?

#!/bin/bash

remote=:7
res=1024x768

xpra info &>/dev/null && xpra stop $remote

xpra start $remote \
     --use-display=auto --desktop-scaling=$res \
     --speaker=on --env=XPRA_CUTTER_THRESHOLD=0 \
     --border=\#CC00CC --start="chromium 'https://www.youtube.com/watch?v=w-XZu8DBLSs'"

for ((w=10;w>0;w--)); do echo -n $w..; sleep 1s; done

#xpra attach $remote

ffmpeg -f x11grab -framerate 25 -video_size $res \
       -probesize 64M -thread_queue_size 128 -i $remote.0+20,60 \
       -f pulse -ac 2 -thread_queue_size 32 -i default \
       -preset ultrafast ~/Videos/$(date -Iseconds)-capture.mkv

2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
Note: See TracQuery for help on using queries.