Xpra: Ticket #1146: KDE - System Tray Icon is tiny

As the title suggests, when using the latest Plasma Desktop in Fedora 23, Xpra clients create a very very very small icon in the system tray. I would guess that it's 4x4 pixels in size. It works perfectly fine, but is very hard to click.

I'll attach a screenshot to demonstrate.


Fedora 23 64-bit

Xpra trunk r12147

Tue, 15 Mar 2016 20:25:02 GMT - J. Max Mena: attachment set

screenshot to demonstrate. The icon is between the printer and the sound icons...it's quite small.

Tue, 15 Mar 2016 20:43:33 GMT - J. Max Mena:

For the life of me I have no idea how to get the KDE version....

If you want logs of some sort, let me know.

Wed, 16 Mar 2016 05:17:40 GMT - Antoine Martin:

Could be related to #1016.

Thu, 17 Mar 2016 09:07:42 GMT - Antoine Martin: status changed

See also https://bugzilla.redhat.com/show_bug.cgi?id=1231759

Sun, 27 Mar 2016 17:29:16 GMT - Antoine Martin: owner, status changed

This may help: r12242 + r12245

@maxmylyn: does it make any difference, please include the -d tray output

Mon, 28 Mar 2016 05:57:20 GMT - Antoine Martin: attachment set

systray looking fine with Kubuntu 14.04

Mon, 28 Mar 2016 08:44:23 GMT - Antoine Martin: priority changed; keywords set

As can be seen here (tested with 0.17 latest): systray looking fine with Kubuntu 14.04 The systray looks fine with Trusty (I also tested with 0.16.3) - maybe KDE 4.13 is before the breakage?, it also looks fine with opensuse 13.2 which uses KDE 4.14 (tested with both xpra 0.16 and 0.17) but I do see the problem with Fedora 23 (also KDE 4.14)... (I wanted to try KDE on Ubuntu 15.10, but it just won't load the desktop)

It is kind of "fixed" by the changes from comment:4 (which I will backport) in that at least the systray is more or less the right size now, but it still doesn't look great, and even more strange: it worked the first time I connected, but not the second. (something in KDE is getting wedged badly - you have to logout and log back in to make it work again, what an epic fail) Even worse: the clicks on the tray do nothing if you click+release quickly, despite the fact that we receive exactly the same events as when doing a slow click+release. This can be seen with -d tray,menu. The exact same code also fires when doing a Alt+Shift+F1, except this works every time.

For more details on this API horror show, see ticket:1016#comment:1.

@maxmylyn: if the size is improved, let's close this ticket and follow up in #1016.

Mon, 28 Mar 2016 18:03:00 GMT - J. Max Mena: status changed; resolution set

Well.....at least it's clickable, and the size is more or less what it should be.

I am also seeing the issue where it won't show back up again until I log out and back in...I guess I'll just have to refrain from disconnecting ;)


Mon, 13 Jun 2016 21:29:05 GMT - J. Max Mena:

Of note as of the week of 6/13/2016:

There must have been an update with KDE because my Icon comes back after disconnecting and reconnecting. Either way it's working fine now.

Sat, 23 Jan 2021 05:16:15 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1146