Xpra: Ticket #1240: launcher does not honour SSH password on OSX

The client says that connection is lost. However, binding tcp works.

Starting the client from the commandline allowed me to see output of the client. Looks like there's a python error, and then it asks for my password to the remote server. Providing the correct password connects and everything works from there. Details are in the bug report attached.

Fri, 24 Jun 2016 20:22:13 GMT - Chris B: attachment set

Bug report

Sat, 25 Jun 2016 04:26:14 GMT - Antoine Martin: status changed

The stacktrace from the bug report tool is:

Traceback (most recent call last):
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/gui.py", line 370, in ready
  File "/Applications/Xpra.app/Contents/Resources/lib/python/xpra/platform/darwin/gui.py", line 385, in setup
    class Delegate(NSObject):
error: Delegate is overriding existing Objective-C class

Could be caused by the sleep / wake (#1137 / r12271) or the tray deiconify hook. (#965 / r12162) This should not be fatal.

@uberbrodt: you will not be prompted for a password when using the GUI, you should be typing in your password there. I will check that this still works as expected. From the bug report, the OS is "El Capitan" (Darwin-15.5.0-x86_64-i386-32bit) so maybe the SSH password script stopped working on this version of the OS.

Tue, 28 Jun 2016 00:56:26 GMT - Chris B:

When running from the GUI, I was typing the password into the provided input, but it was giving me a "connection closed" error (or something like that). I only tried the command line after that. I am on the latest El Capitan. Thanks for looking into this so quickly!

Tue, 12 Jul 2016 16:52:22 GMT - Antoine Martin: milestone changed

Milestone renamed

Thu, 04 Aug 2016 08:59:42 GMT - Antoine Martin: owner, status, summary changed

The Delegate stacktrace is unrelated, I am moving it to #1277.

The SSH problem only occurs when using the launcher (I have edited the ticket summary to clarify). We were shipping an SSH_ASKPASS script, but we never hooked it up, in any case the ssh process does not seem to honour it (tested on OSX and Linux), despite those claims:

So a much better solution is to use sshpass, which is available for Fedora, Debian, etc... but not centos. r13201 does this, including the packaging updates for building it on OSX. (need updates up to r13207 to fix some epic bloopers I made along the way)

Tested on OSX and Fedora. @uberbrodt: please test the latest http://xpra.org/beta and close if this works for you.

Wed, 10 Aug 2016 04:23:15 GMT - Antoine Martin: owner changed

@smo: over to you.

Wed, 10 Aug 2016 10:34:52 GMT - DavidE:

Help appreciated. I installed newer beta version and it seemed to get farther (didn't immediately disconnect) but the GUI just disappeared and nothing more happened. [i.e., I was waiting for a window to open and it never did]

Wed, 10 Aug 2016 10:37:33 GMT - Antoine Martin:

@davide: see ticket:1281#comment:1 and try from the command line so you can see what is happening in more detail. You have yet to include what version you are using or what command lines you used to start the server, show the server log file, etc. All making it really hard to follow what you are doing.

Wed, 10 Aug 2016 10:44:51 GMT - DavidE:

As you suggested I am using the latest version of the gui and have showed you in the screenshot the entirety of what I am trying. I am on El Capitan.

I have no command line version in MAC so cannot try what you said

Wed, 10 Aug 2016 10:48:12 GMT - Antoine Martin:

have showed you in the screenshot the entirety of what I am trying

Blatantly not. See ticket:1281#comment:1, server version still missing, server command still missing, have you tried connecting from an ubuntu client? also missing. Server log, missing.

I have no command line version in MAC so cannot try what you said

Again. See comment.

Sat, 13 Aug 2016 19:04:52 GMT - Chris B: status changed; resolution set

Downloaded the beta today and tested. Works like a champ. Thanks!

Sat, 23 Jan 2021 05:18:50 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1240