Xpra: Ticket #1281: xpra ssh mode cannot connect from mac gui launcher

I have a Ubuntu server running a session on Display :30

I can connect/disconnect from it remotely and even locally on my mac through ssh -X (which defeats the point).

However, whenever I try the xpra launcher with all the right settings, I just get the red 'Connection lost' with no explanation. Also, there is no documentation.

Maybe if I had the command-line version of xpra I could try attach but I can't find it for MAC. This could be really good, but as is, it is unusable. Such a shame...

Wed, 10 Aug 2016 10:00:33 GMT - Antoine Martin: owner changed

What version are you using? What mode are you using to try to connect? What commands lines are you using to start xpra? Does it work if you connect from Ubuntu? etc.. for more guidelines, see wiki/ReportingBugs.

Xpra is used every day on macs.

The Xpra executable will be on your path if you use the PKG installer, otherwise it will be found in Xpra.app/Contents/Helpers/Xpra

Finally, there is tons of documentation, here on this wiki and via the xpra man page.

Wed, 10 Aug 2016 10:10:27 GMT - DavidE: attachment set

Wed, 10 Aug 2016 10:14:13 GMT - Antoine Martin: status changed; resolution set

So you're using SSH mode, you may want to try the latest beta osx builds which include a fix for ssh mode. Or use ssh keys.

See #1240

Wed, 10 Aug 2016 10:18:00 GMT - Antoine Martin: summary changed

Wed, 10 Aug 2016 10:37:48 GMT - Antoine Martin:

See ticket:1240#comment:7

Wed, 10 Aug 2016 11:22:40 GMT - DavidE: status changed; resolution deleted

The Beta version still doesn't work with my El Capitan.

I tried at commandline

./Xpra ssh:username@ipaddress:display

and got the error

xpra: error: invalid mode 'initenv'

Wed, 10 Aug 2016 11:25:07 GMT - Antoine Martin: status changed; resolution set

Had you replied to my questions in comment:1, which I have now repeated numerous times, we would all have saved a lot of time. Your xpra version on the server is too old. More details here: wiki/Versions

Also, please always include the exact command you typed (cut&pasting them), the ones from comment:5 are made up, and wrong.

Wed, 10 Aug 2016 12:47:53 GMT - DavidE: status changed; resolution deleted

It is true the previous server was old.

However I just tried the beta version with an xpra session on a brand new server and got the error

'server requested disconnect: login timeout

[El Capitan trying to connect to current Ubuntu]

Wed, 10 Aug 2016 13:00:31 GMT - DavidE:

I tried connecting through ssh -X on this server and got lots of libGL errors

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
The program 'Xpra' received an X Window System error.
This probably reflects a bug in the program.
The error was 'GLXBadContext'.
  (Details: serial 261 error_code 160 request_code 150 minor_code 6)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Thu, 11 Aug 2016 12:22:43 GMT - Antoine Martin: status changed

opengl has nothing to do with your problem, no idea what "I tried connecting through ssh -X" means since you're still not including the actual commands you used.

Try with the latest beta, which will allow you to disable ssh host key checking. Maybe you never connected to that SSH server before and SSH strict host key checking is enabled but without support for GUI confirmation.

Here's what a proper debugging information looks like:

(and keep an eye on your server log)

(you can omit the display part if you have a single server session running)

Unless you can provide similar details showing your exact problem, in particular any output or error messages, I will close this bug.

Sat, 13 Aug 2016 23:38:28 GMT - DavidE:

OK I will try tomorrow

Sun, 14 Aug 2016 17:38:14 GMT - DavidE: attachment set

Mon, 15 Aug 2016 03:45:50 GMT - Antoine Martin:

Info still missing. How many times can I ask for the same thing? This will be the last. See comment:1 and ticket:1240#comment:9, comment:9 right above for an example.

Mon, 15 Aug 2016 08:08:06 GMT - DavidE: attachment set

Attempt from Ubuntu to Ubuntu

Mon, 15 Aug 2016 08:14:25 GMT - DavidE:

OK - I tried your suggestion to test whether Ubuntu would connect, and the answer was 'no' for the new server. [see attachment 3]

I had tested the old server [Ubuntu 10.2] for the same thing and it had worked. I hadn't checked the new one for this but it appears this could be the issue - that the current version of Xpra is not compatible with Ubuntu 16 without further tweaking.

Mon, 15 Aug 2016 09:23:13 GMT - Antoine Martin: status changed; resolution set

The current version of xpra for Ubuntu xenial is 0.17.4, more details here: wiki/Versions - same as comment:6. Details as per comment:9 are still missing too, so I'm done.

Wed, 01 Mar 2017 20:56:25 GMT - Alain Kalker:

Dear Antoine,

Please, could you drop the condescending tone, get some sleep, whatever. Not all users of Xpra are professional bug reporters, or even have any experience in reporting problems.

I think I'm having a similar problem to DavidE: I'm unable connect to a Linux server using the GUI part of Xpra for Mac OS.

I'm attaching a zip file which was saved after clicking the "Bug Report" icon in the Xpra GUI.

Wed, 01 Mar 2017 20:57:08 GMT - Alain Kalker: status changed; resolution deleted

Wed, 01 Mar 2017 21:40:40 GMT - Alain Kalker:

Tried to repro just to be absolutely sure but I was unable to. There was a problem with the connection between the Mac client and Linux server, unrelated to Xpra. After fixing this, both commandline xpra attach and the GUI worked well.

It would have been nice if the error message reported by the GUI had been more indicative of the root cause of the problem.

Wed, 01 Mar 2017 21:42:19 GMT - Alain Kalker: status changed; resolution set

Sat, 23 Jan 2021 05:19:59 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1281