Xpra: Ticket #1652: black screen

When I try attaching all I get is a black screen. My client is on windows 10 running Xpra 2.1.2 64bit rev 16904

Server installed from the winswitch report is xpra v2.1.2-r16903 running on Lubuntu 17.04 Linux johnny 4.10.0-19-generic #21-Ubuntu SMP Thu Apr 6 17:04:57 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I've tried starting the desktop with the following. All I get is a black screen. Can't click or anything.

xpra start-desktop --start-child=lxsession
xpra start-desktop --start-child="lxsession -s LXDE -e LXD"

If I start with:

xpra start-desktop --start-child=openbox-lubuntu

I get a black screen but I can right click and get a menu but its super small.

I just installed xterm (apparently wasn't installed by default) and I can run "xpra start --start-child=xterm" and attach to it just fine though.

Wed, 20 Sep 2017 19:10:12 GMT - Antoine Martin: owner, description changed

Just tried it on an Ubuntu 17.04 VM after installing "lxsession" and the desktop showed up as expected. If it doesn't work on your system, make sure that your client is working properly: turn off opengl, try a simple xterm, etc. And try executing "lxsession" from an xterm so you can see any error messages there.

The font issue was a DPI problem, the patched dummy driver update (#1215) for Ubuntu 17.04 was missing. Just update and you'll get it now.

Sun, 01 Oct 2017 10:00:51 GMT - Antoine Martin: status changed; resolution set

Not heard back, closing.

Sat, 23 Jan 2021 05:30:09 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1652