xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.

Opened 5 years ago

Closed 5 years ago

Last modified 17 months ago

#1652 closed defect (worksforme)

black screen

Reported by: williamt Owned by: williamt
Priority: major Milestone: 2.2
Component: android Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

When I try attaching all I get is a black screen.
My client is on windows 10 running Xpra 2.1.2 64bit rev 16904

Server installed from the winswitch report is xpra v2.1.2-r16903
running on Lubuntu 17.04 Linux johnny 4.10.0-19-generic #21-Ubuntu SMP Thu Apr 6 17:04:57 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I've tried starting the desktop with the following. All I get is a black screen. Can't click or anything.

xpra start-desktop --start-child=lxsession
xpra start-desktop --start-child="lxsession -s LXDE -e LXD"

If I start with:

xpra start-desktop --start-child=openbox-lubuntu

I get a black screen but I can right click and get a menu but its super small.

I just installed xterm (apparently wasn't installed by default) and I can run "xpra start --start-child=xterm" and attach to it just fine though.

Change History (3)

comment:1 Changed 5 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to williamt

Just tried it on an Ubuntu 17.04 VM after installing "lxsession" and the desktop showed up as expected.
If it doesn't work on your system, make sure that your client is working properly: turn off opengl, try a simple xterm, etc. And try executing "lxsession" from an xterm so you can see any error messages there.

The font issue was a DPI problem, the patched dummy driver update (#1215) for Ubuntu 17.04 was missing. Just update and you'll get it.

Version 1, edited 5 years ago by Antoine Martin (previous) (next) (diff)

comment:2 Changed 5 years ago by Antoine Martin

Resolution: worksforme
Status: newclosed

Not heard back, closing.

comment:3 Changed 17 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1652

Note: See TracTickets for help on using tickets.