xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.

Opened 5 years ago

Closed 5 years ago

Last modified 16 months ago

#1674 closed defect (fixed)

Client crash on launch

Reported by: Jiang Owned by: Antoine Martin
Priority: blocker Milestone: 1.0
Component: server Version: trunk
Keywords: crypto crash Cc:


I'm one of those holdout sticking to 1.0 branch. After the recent upgrade to 1.0.9, server seemingly launched fine but client crash on trying to connect to server.

'module' object

has no attribute 'algorithms_available'

Detailed log attached. Downgrading Client to 1.0.8 while keeping the server in 1.0.9 doesn't help. Furthermore, even trying to shut down the server using xpra stop :100 gives the same error. Server has to be shut down by killing the process manually.

I am running Ubuntu 14.04 64 bit on both side. I run xpra over *wired* LAN with strict access control on the router side, so I do not use encryption or password and run it directly over TCP for maximum framerate. Most of my important traffics are tunneled outside xpra via ssh tunneling.

Attachments (1)

server.log (9.2 KB) - added by Jiang 5 years ago.
server log detailing the crash

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by Jiang

Attachment: server.log added

server log detailing the crash

comment:1 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

This is a server error processing new connection as per the log message, which affected only: Ubuntu Trusty and centos 6.x

The fix is in r17257 and updated packages are available now.

comment:2 Changed 5 years ago by Antoine Martin

Milestone: 1.11.0

comment:3 Changed 16 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1674

Note: See TracTickets for help on using tickets.