Xpra: Ticket #1674: Client crash on launch

I'm one of those holdout sticking to 1.0 branch. After the recent upgrade to 1.0.9, server seemingly launched fine but client crash on trying to connect to server.

'module' object

has no attribute 'algorithms_available'

Detailed log attached. Downgrading Client to 1.0.8 while keeping the server in 1.0.9 doesn't help. Furthermore, even trying to shut down the server using xpra stop :100 gives the same error. Server has to be shut down by killing the process manually.

I am running Ubuntu 14.04 64 bit on both side. I run xpra over *wired* LAN with strict access control on the router side, so I do not use encryption or password and run it directly over TCP for maximum framerate. Most of my important traffics are tunneled outside xpra via ssh tunneling.

Thu, 26 Oct 2017 21:09:15 GMT - Jiang: attachment set

server log detailing the crash

Fri, 27 Oct 2017 05:00:32 GMT - Antoine Martin: status changed; resolution set

This is a server error processing new connection as per the log message, which affected only: Ubuntu Trusty and centos 6.x

The fix is in r17257 and updated packages are available now.

Thu, 02 Nov 2017 11:54:49 GMT - Antoine Martin: milestone changed

Sat, 23 Jan 2021 05:30:45 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1674