Xpra: Ticket #1858: issue without MIT-SHM

System: debian 9, winswitch repository.

I am facing an issue I currently can not encircle well. Maybe you have an idea nonetheless.

I am using xpra to locally display X applications in docker containers. I am starting Xvfb or Xdummy on myself with disabled extension MIT-SHM. Afterwards, I run xpra with --use-display.

I have no issue up to xpra v2.2.5-r18663. Since xpra v2.2.6-r18969 I get this error message in xpra server log immediatly after the client has connected to server:

2018-05-29 13:46:31,307 get_image(0, 0, 300, 300) get_image local variable 'shm_image' referenced before assignment
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/xpra/x11/gtk2/window_damage.py", line 176, in get_image
    if shm_image:
UnboundLocalError: local variable 'shm_image' referenced before assignment

The message appears if applications do OpenGL requests. With glxgears it repeats a few hundred times within a few seconds and never stops. Changing xpra options seems to have no effect, especially I tried --mmap=no and disabling OpenGL in xpra client tray icon. Using either Xvfb or Xdummy does not make a difference.

The error disappears if I allow extension MIT-SHM, but then I have to share host IPC namespace with container. I want to avoid that as that degrades container isolation.

I did not succeed to set up a short example to reproduce, sorry. If you want to try out with x11docker itself, please install x11docker release 4.3.0 from github and run:

x11docker --xpra --verbose --no-auth x11docker/lxde glxgears

Tue, 29 May 2018 12:34:13 GMT - Antoine Martin: owner changed; milestone set

Does r19518 fix things?

Tue, 29 May 2018 12:48:40 GMT - mviereck:

Could you please push a build in winswitch beta repository for debian stretch? I am getting xpra v2.4-r19479 currently. Looking at your code change it will most probably fix it.

Tue, 29 May 2018 13:25:55 GMT - Antoine Martin:

Could you please push a build in winswitch beta repository for debian stretch?


Tue, 29 May 2018 13:29:54 GMT - mviereck:

The bug is fixed, thank you!

Tue, 29 May 2018 13:30:06 GMT - mviereck: status changed; resolution set

Tue, 29 May 2018 13:41:54 GMT - Antoine Martin:

This will be included in 2.3.1: r19519

Sat, 23 Jan 2021 05:35:39 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1858