Xpra: Ticket #1895: Modal Window in Xpra

It is not possible for now to use modal window on xpra. Is it possible to add on option to allow it ?

Wed, 04 Jul 2018 08:11:40 GMT - Antoine Martin: owner, component changed; milestone set

Done in r19834.

If you start the client with XPRA_MODAL_WINDOWS=1 then the client will set the modal flag on windows.

@ibuprofene: does that work for you? some beta packages posted here: https://xpra.org/beta (let me know if your distro doesn't have builds recent enough)

We could turn this option into a tray menu toggle. (but I'm not sure if toggling the modal flag would affect existing windows properly or not)

Fri, 06 Jul 2018 13:57:31 GMT - ibuprofene:

Hello, It doesn't work with my current version: xpra v2.3.1-r19531 I will try with a beta as soon as possible. I use CENTOS

Fri, 06 Jul 2018 16:20:06 GMT - Antoine Martin:

It doesn't work with my current version: xpra v2.3.1-r19531

This flag is only in the beta builds at present. If this works for you, I will then apply it to the stable 2.3.x branch.


Which release? 7.5?

Sat, 07 Jul 2018 10:28:05 GMT - Antoine Martin:

In any case, there are now beta packages for all centos7 releases.

r19869 enabled this by default (since I haven't encountered any problems with it so far - can revert later), adds a command line option (modal-windows=yes|no) and a toggle in the system tray.

We could also make the tray toggle apply to existing windows, rather than only apply to new windows. (using a setter method on the client to iterate over the windows and set the value from the metadata cache)

Tue, 10 Jul 2018 12:40:13 GMT - Antoine Martin: status changed; resolution set

r19906 re-sets the flag on all the windows whenever the value in the system tray menu is toggled.

That will do.

Tue, 10 Jul 2018 16:51:09 GMT - ibuprofene:

Ok so I tried the new version of xpra but it didn't work properly, when I start the client it says "VM blacklisted" and it doesn't work. Notice that it could be another problem, I will try on an other machine and I'll tell you.

Tue, 10 Jul 2018 16:55:14 GMT - Antoine Martin:

Ok so I tried the new version of xpra but it didn't work properly,

What exact version?

when I start the client it says "VM blacklisted"..

What is the exact message? Is this the opengl message? (this one has not changed at all for a while)

and it doesn't work

What is "it"? The client? The connection? The modal windows?

Tue, 10 Jul 2018 19:41:22 GMT - ibuprofene:

Hello, thank you for your reactivity:

xpra v2.4-r19869

Yes it was the openGL message, I don't have this issue anymore. The "it" is the whole thing, when I start the client both client and servers crash

Tue, 10 Jul 2018 19:58:56 GMT - Antoine Martin:

The "it" is the whole thing, when I start the client both client and servers crash

That's very very unlikely. What is the client output and server log?

Tue, 10 Jul 2018 20:27:26 GMT - ibuprofene:

Well I'm not working on this machine anymore so I cannot tell you exactly what was the output, I will have access tomorrow when I'll go back to my work, I'll send you evrything then.

I have just created a new VM with centos 7.5 to test your patch, so I've installed xpra and xpra --version returns: xpra v2.4-r19869

So I think it is the good one Then I use the following comand line:

xpra start :99 --daemon=no --start-via-proxy=no --webcam=no --start-new-commands=yes \
   --encodings=rgb,png,h264,vp8,vp9 --quality=100 --min-quality=95 --pixel-depth=24 \
   --mdns=no --html=yes --bind-tcp= --pulseaudio=no --resize-display=no \
   --file-transfer=yes --printing=no --speaker=disabled --microphone=disabled \
   --exit-with-children --modal-windows=yes --start-child="myapp"

on server and I use the browser to connect and I don't have my modal window, but I think I miss something, I don't understand what you mean by " a toggle in the system tray", is there something else to do ?

Thank you again

Wed, 11 Jul 2018 02:40:39 GMT - Antoine Martin:

and I use the browser to connect

You must be joking. You are using the HTML5 client and you only mention this in comment:10. All the work I did was for the regular python client.

Please file a separate ticket for that, and make it clear that this is for the HTML5 client as per wiki/ReportingBugs.

Wed, 11 Jul 2018 07:33:01 GMT - ibuprofene:

No you did well, so far I was using the python client but yesterday as I hadn't xpra on my machine I tried with the browser, I thought It was the same, sorry, I apologize, but anyway even with the python client I don't have my modal window :(

Wed, 11 Jul 2018 13:16:59 GMT - ibuprofene:

Ok so I came back on my computer and I realized that I had edited some env variables and there was aparently a conflit between my X server and Xpra so I changed it and now it's fine, and wow the modal works ! Thank you very much ! Excuse me if I wasn't clear sometimes, I'll try to be more precise in the future because I have an other bug to report.

Sat, 13 Apr 2019 06:11:26 GMT - Antoine Martin:

Caused a regression: #2270, so this is now disabled again by default in 2.5.x - a different fix has been applied for 3.0. (see ticket:2270#comment:4 for details)

Fri, 03 Apr 2020 12:25:57 GMT - Antoine Martin:

Disabled by default again: #2706

Sat, 23 Jan 2021 05:36:38 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1895