Xpra: Ticket #1901: ctrl-click not working in HTML5 client

I found this issue when running xpra in a Docker container with Ubuntu 17.10 artful and using the HTML5 client. This bug is present in both version of xpra and only in HTML5 client.

If I run "firefox https://xpra.org" in the remote xterm terminal window, Firefox launches regularly and the web page loads fine. If I ctrl+click on a link, for example on About, the link is opened in the same tab instead of a new one. If I use the desktop client, the ctrl+click opens the link in a new tab as expected.

I wrote a couple of Dockerfiles to test the latest stable (xpra X11 version 2.3.2-r19729 64-bit as of this writing) and the latest beta version (xpra X11 version 2.4-r19803 64-bit as of this writing) and I found some bugs when comparing the HTML5 client to the Xpra desktop client I use on my Arch Linux running PC.

The Docker images are based on Ubuntu 17.10 artful and I attach the Dockerfiles so that my experiments can be reproduced.

To build the images, I run the following commands:

sudo docker build -t xpra -f path/to/xpra/Dockerfile path/to/xpra/
sudo docker build -t xpra:beta -f path/to/xpra/Dockerfile-beta path/to/xpra/

To run the containers, I enter the following:

sudo docker run --interactive --tty --rm -p 8080:8080 xpra
sudo docker run --interactive --tty --rm -p 8080:8080 xpra:beta

Thu, 05 Jul 2018 11:09:54 GMT - Matteo Ipri: attachment set

Thu, 05 Jul 2018 11:10:15 GMT - Matteo Ipri: attachment set

Thu, 05 Jul 2018 11:10:20 GMT - Matteo Ipri: attachment set

Thu, 05 Jul 2018 12:18:24 GMT - Antoine Martin: status, description changed; milestone set

Tue, 10 Jul 2018 02:32:26 GMT - Antoine Martin: owner, status, description changed

Fixed in r19903.

Tue, 10 Jul 2018 10:57:20 GMT - Matteo Ipri: status changed; resolution set

Thank you very much. I just tested the changes and they fix the issue.

Sat, 23 Jan 2021 05:36:48 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/1901