xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Changes between Initial Version and Version 1 of Ticket #2022, comment 25


Ignore:
Timestamp:
11/06/18 13:23:09 (3 years ago)
Author:
Antoine Martin
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #2022, comment 25

    initial v1  
    1111[nathan@bobross lsprepost4.5_centos7]$
    1212}}}
    13 
    14 https://xpra.org/trac/attachment/ticket/2022/15.txt
     13[/attachment/ticket/2022/15.txt]
    1514
    1615I *was not* able to replicate using the same commands when connected on either 802.11g or 802.11n.  In all cases I was port forwarding ssh.  This trouble arises *only* on cell phone and broadband.  Broadband is an especially important case, however, because we have several offsite users.
    1716
    1817How do I get debug log off the client?
    19 
    20 
    21 >
    22 >
    23 > From the 14.txt log:
    24 > * a strange error:
    25 > {{{
    26 > Warning: XShm get_pixels_ptr XImage is NULL
    27 > nvenc(XRGB/NV12/H264 - hp -  520x188 ).compress_image(XShmImageWrapper(BGRX: 0, 0, 520, 189), 40, 99, {'av-sync': True, 'bandwidth-limit': 0, 'content-type': ''})
    28 >   Traceback (most recent call last):
    29 >   File "/usr/lib64/python2.7/site-packages/xpra/server/window/window_video_source.py", line 1921, in do_video_encode
    30 >    ret = ve.compress_image(csc_image, quality, speed, options)
    31 >   File "xpra/codecs/nvenc/encoder.pyx", line 2179, in xpra.codecs.nvenc.encoder.Encoder.compress_image
    32 >   File "xpra/codecs/nvenc/encoder.pyx", line 2216, in xpra.codecs.nvenc.encoder.Encoder.do_compress_image
    33 >   File "xpra/codecs/nvenc/encoder.pyx", line 2245, in xpra.codecs.nvenc.encoder.Encoder.copy_image
    34 > AssertionError: failed to get pixels from XShmImageWrapper(BGRX: 0, 0, 520, 189)
    35 > }}}
    36 > No idea what caused this. Unless this happens repeatedly, I think we can ignore this.
    37 > * there's a lot of re-cycling going on, which is why things are slow, every time an nvenc context is (re)created, the initial frame takes ~400ms:
    38 > {{{
    39 > compress: 429.1ms for 1632x914  pixels at    0,0    for wid=1     using      h264 with ratio   3.4%  ( 5833KB to   197KB), sequence    13, client_options={u'speed': 99, u'frame': 0, u'pts': 0, 'csc': u'XRGB', u'quality': 40}
    40 > }}}
    41 > Please enable {{{XPRA_DEBUG_VIDEO_CLEAN=1}}} for that.