xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 9 years ago

Closed 9 years ago

Last modified 8 months ago

#211 closed defect (invalid)

Killing xpra requires password

Reported by: ahuillet Owned by: Antoine Martin
Priority: major Milestone: 0.8
Component: core Version: trunk
Keywords: Cc:

Description

Hello,

when trying to kill an xpra session that uses a password, the operation fails because it requires a password itself.

# xpra stop :2
password is required by the server
Failed to shutdown xpra at :2

Is that by design or not? I'd rather it was possible to kill the session without a password (because I can just use "kill" anyway so requiring a password doesn't make sense), but perhaps I'm missing something.

Thanks

Change History (2)

comment:1 Changed 9 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

This is by design, the server has no way of knowing if the user accessing the socket does have sufficient permissions to stop/kill the server.

The socket could be:

  • fully public: tcp
  • semi-public: unix domain socket with chmod, "shared" ssh limited account
  • private: everything else

comment:2 Changed 8 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/211

Note: See TracTickets for help on using tickets.