xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 2 years ago

Closed 2 years ago

Last modified 8 months ago

#2267 closed defect (invalid)

not adding a duplicate printer but still use it

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 3.0
Component: printing Version: 2.5.x
Keywords: Cc:

Description

Caused by #2095.
When we find that the printer already exists on the server, we don't add it again.
Then when we try to print to it, the server tries to find the client that added it and doesn't find it... and nothing gets printed.
Looks like we need to keep track of the printers we meant to add separately, so we can find the client to send the job to.

Change History (2)

comment:1 Changed 2 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

Not really a problem I think.
We match the uuid not the printer name, and the code just needed fixing for python3: r22366.

comment:2 Changed 8 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2267

Note: See TracTickets for help on using tickets.