xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Changes between Initial Version and Version 1 of Ticket #2568


Ignore:
Timestamp:
01/30/20 08:43:51 (20 months ago)
Author:
Antoine Martin
Comment:

That's odd, the turbojpeg dependencies have not changed since r17388, 2 years ago. I did find r24346 and the r24347 backport but this only applies to python3 packages and therefore not relevant to centos7, so the installation should have pulled turbojpeg which does provide libturbojpeg.so.0.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #2568

    • Property Owner changed from Antoine Martin to Bill Randle
  • Ticket #2568 – Description

    initial v1  
    11I did look through open tickets and saw some similar ones, but not addressing this exact issue. If there is a known workaround, feel free to close this with a reference.
    22
    3 Added the xpra.repo file to /etc/yum.repos.d and set the url to:
     3Added the xpra.repo file to {{{/etc/yum.repos.d}}} and set the url to:
     4{{{
    45  https://xpra.org/dists/RedHat/$releasever/$basearch/
     6}}}
    57
    68On install, I got the following dependency errors:
     9{{{
    710Error: Package: python2-xpra-3.0.5-0.r24939xpra1.el7_7.x86_64 (xpra)
    811           Requires: libturbojpeg.so.0()(64bit)
     
    1114Error: Package: python2-xpra-3.0.5-0.r24939xpra1.el7_7.x86_64 (xpra)
    1215           Requires: libturbojpeg.so.0(TURBOJPEG_1.0)(64bit)
    13 
     16}}}
    1417RHEL7.7 provides:
     18{{{
    1519  libjpeg-turbo-1.2.90-8.el7.x86_64
    1620  libjpeg-turbo-utils-1.2.90-8.el7.x86_64
     21}}}
    1722which I have installed.
    1823
    19 The libjpeg-turbo package installs:
     24The {{{libjpeg-turbo}}} package installs:
     25{{{
    2026  /usr/lib64/libjpeg.so.62
    2127  /usr/lib64/libjpeg.so.62.1.0
    22 
     28}}}