xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 20 months ago

Last modified 9 months ago

#2607 closed defect

Mouse pointer not visible — at Version 2

Reported by: stdedos Owned by: Antoine Martin
Priority: major Milestone: 4.0
Component: client Version: 3.0.x
Keywords: Cc:

Description (last modified by Antoine Martin)

I am resurrecting #2300, with a small twist:

From / To my Xenial server:

$ xpra --version
xpra for python 2.7 is not installed
 retrying with python3
xpra v3.0.6-r25174

And mouse pointer won't come up with nothing

raw-attachment/ticket/2607/Screencast%202020-02-21%2012%3A00%3A15.mp4

Change History (4)

Changed 20 months ago by stdedos

Changed 20 months ago by stdedos

Attachment: _usr_bin_xpra.1000.crash added

comment:1 Changed 20 months ago by stdedos

I found a small core during the experiment. Maybe it is useful in some part?

I also found a 9MB-core - maybe that's the opengl-core we have already discussed?

Last edited 20 months ago by stdedos (previous) (diff)

comment:2 Changed 20 months ago by Antoine Martin

Description: modified (diff)
Status: newassigned

And mouse pointer won't come up with nothing

Will check.
The -d cursor client log output would be good to have, just when you move over the window and it goes blank.
It is possible that this is a problem with your local theme, in which case this will help:

XPRA_USE_LOCAL_CURSORS=0 xpra attach ...

I found a small core during the experiment. Maybe it is useful in some part?
NameError: name 'ss' is not defined

That's already been fixed in r25193.
I even re-issued 3.0.6 with this fix on top, the problem is that every build succeeded (including xenial 32-bit) except for xenial 64-bit! (which is what you're using).

Note: See TracTickets for help on using tickets.