xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 16 months ago

Closed 16 months ago

Last modified 8 months ago

#2761 closed defect (fixed)

Xpra stop not working after update

Reported by: zenarcher007 Owned by: Antoine Martin
Priority: critical Milestone:
Component: server Version: 4.0.x
Keywords: stop Cc: jdouty03@…

Description

After using the latest version of xpra as a server, I noticed that you could start sessions on a display using

xpra start :(display number, ex. 350)

but they would never fully stop with the xpra stop command. Everything else seemed to work fine.
Through trial and error, I determined that this issue started between these two versions:

This version and older, xpra stop :(display) was working vv

xpra_4.0-20200331r25881-1_amd64.deb 2020-03-31 13:45 2.8M

This version and newer, xpra stop :(display) was NOT working vv

xpra_4.0-20200410r26081-1_amd64.deb 2020-04-10 17:14 2.8M

The output from "xpra stop all" on a non-working version:

server requested disconnect:
 server shutdown
How odd... I'm not sure what's going on with xpra at :351

The output from "xpra stop :350" on a non-working version:

server socket for display :350 is in UNKNOWN state
 waiting up to 20 seconds
Warning: failed to connect:
 cannot find live server for display :350

The oldest tested version was:

xpra_4.0-20200308r25538-1_amd64.deb 2020-03-07 17:18 2.8M

The most recent tested version was:

xpra_4.0-20200505r26253-1_amd64.deb 2020-05-04 20:25 2.8M

The issue still persists, not letting me start another server on the same display as the one I tried to shut down, even after removing /tmp/.X350-lock (unless I use --use-display). The only thing that seems to fix this on a non-working (more recent) version is a reboot.

Attachments (2)

:350.log (4.7 KB) - added by zenarcher007 16 months ago.
On the new, not working, version, up to trying to shut it down.
:350.log.new (932 bytes) - added by zenarcher007 16 months ago.
Trying to start a new session, still on the newer version

Download all attachments as: .zip

Change History (7)

Changed 16 months ago by zenarcher007

Attachment: :350.log added

On the new, not working, version, up to trying to shut it down.

Changed 16 months ago by zenarcher007

Attachment: :350.log.new added

Trying to start a new session, still on the newer version

comment:1 Changed 16 months ago by Antoine Martin

Status: newassigned

From the log:
Linux Ubuntu 20.04 focal

comment:2 Changed 16 months ago by Antoine Martin

Thanks for the bug report, I haven't identified the cause of this bug, but I do have a workaround you can use:

XPRA_CLOSE_GTK_DISPLAY=0 xpra start ...

Or even:

xpra start --env=XPRA_CLOSE_GTK_DISPLAY=0 ...

This prevents the crash when the server terminates.

comment:3 Changed 16 months ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

This version and older, xpra stop :(display) was working vv
xpra_4.0-20200331r25881-1_amd64.deb 2020-03-31 13:45 2.8M

This version also crashes. I've tried going back even further, they all crash.

My guess is that this is a GTK library update that caused the crash to start to occur around that time.
So r26335 changes the default to never close the display on exit.

Version 0, edited 16 months ago by Antoine Martin (next)

comment:4 Changed 16 months ago by Antoine Martin

comment:3 was wrong, I was just testing badly.
Bisecting:

So r26337 is the more correct fix, but I'm going to keep r26335 because this close_gtk_display has caused too many bugs already.

comment:5 Changed 8 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2761

Note: See TracTickets for help on using tickets.