xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 8 months ago

Closed 8 months ago

Last modified 5 months ago

#2921 closed defect (fixed)

win32 bubbles not showing on some systems

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 4.1
Component: platforms Version: 3.0.x
Keywords: Cc:

Description

The code is horrible, but it used to work at least in some cases.

Now it works on my 32-bit windows 7 test system, but not the others...

Change History (2)

comment:1 Changed 8 months ago by Antoine Martin

Resolution: fixed
Status: newclosed

Fixes and related changesets in:

  • r27823 switch to GetModuleHandleExA
  • r27824 debug
  • r27825 fix import side effect causing test script failure
  • r27826 better ctypes argtypes
  • r27827 allow up to the limit given (minor fix)
  • r27832 remove XP compat, add 'A'scii function definition
  • r27833 make it easier to switch between 'A'scii and 'W'ide variants
  • r27834 unify code

For backports, it is probably easier to just take the files wholesale (minus the XP compat code for v3?)

Hopefully this will fix #2738 and #2920.


The easiest way to test those notifications bubbles is with the improved test script: r27836.

Version 2, edited 8 months ago by Antoine Martin (previous) (next) (diff)

comment:2 Changed 5 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2921

Note: See TracTickets for help on using tickets.