xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 7 months ago

Closed 7 months ago

Last modified 6 months ago

#2980 closed defect (duplicate)

Cannot install stable version on debian bullseye / python3<3.9 not available

Reported by: mviereck Owned by: Antoine Martin
Priority: major Milestone: 4.1
Component: packaging Version: 3.0.x
Keywords: Cc:

Description

I've tried to downgrade xpra from beta version to stable, but the installation failed due to unmet dependency python3.9:

$ LANG=C sudo apt install --no-install-recommends xpra
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xpra : Depends: python3 (< 3.9) but 3.9.0-4 is to be installed
E: Unable to correct problems, you have held broken packages.

Installing python2-xpra fails, too:

$ LANG=C sudo apt install --no-install-recommends python2-xpra
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python2-xpra : Depends: xpra but it is not going to be installed
                Depends: python-gtk2 but it is not installable
                Depends: python-gtkglext1 but it is not installable
                Depends: python-opengl but it is not installable
                Depends: python-numpy but it is not installable
                Depends: python-pil but it is not installable
                Depends: python-rencode but it is not installable
                Depends: python-lz4 but it is not installable
                Depends: python-brotli but it is not installable
E: Unable to correct problems, you have held broken packages.

sources.list.d/winswitch.list:

$ cat /etc/apt/sources.list.d/winswitch.list
# deb http://winswitch.org/beta/ bullseye main
deb http://winswitch.org/ bullseye main

Change History (2)

comment:1 Changed 7 months ago by Antoine Martin

Resolution: duplicate
Status: newclosed

As per #2972, we do not rebuild already released versions of the stable branch following every ABI break in Debian Testing, so until a rebuild or the new release hits the stable repository, you will have to use the beta repository. Sorry.

comment:2 Changed 6 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/2980

Note: See TracTickets for help on using tickets.