xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 8 years ago

Closed 8 years ago

Last modified 8 months ago

#355 closed defect (fixed)

xpra server: TypeError: Don't know how to get a display from 16785535L

Reported by: Timo Juhani Lindfors Owned by: Timo Juhani Lindfors
Priority: minor Milestone:
Component: server Version: 0.9.x
Keywords: Cc:

Description (last modified by Antoine Martin)

I frequently see "TypeError: Don't know how to get a display from 16785535L" in the xpra server output:

sauna:~$ xpra start --no-daemon :7
WARNING: low display number: 7
You are attempting to run the xpra server against what seems to be a default X11 display ':7'.
This is generally not what you want.
You should probably use a higher display number just to avoid any confusion (and also this warning message).
/home/lindi/.xpra/sauna-7 is not responding, waiting for it to timeout before clearing it.....

X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-4-amd64 x86_64 Debian
Current Operating System: Linux sauna 2.6.32-5-amd64 #1 SMP Mon Feb 25 00:26:11 UTC 2013 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-amd64 root=UUID=d3fe4b77-110b-4210-a1cf-853333a642be ro quiet
Build Date: 17 April 2013  10:22:47AM
xorg-server 2:1.12.4-6 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.26.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/home/lindi/.xpra/Xorg.:7.log", Time: Sun Jun  9 04:16:49 2013
(++) Using config file: "/etc/xpra/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
2013-06-09 04:16:54,297 server uuid is 2278cf960fa94945918ee89fe3f48041
2013-06-09 04:16:54,732 using notification forwarder: DBUSNotificationsForwarder(org.freedesktop.Notifications)
2013-06-09 04:16:54,749 pulseaudio server started with pid 3999
2013-06-09 04:16:54,752 xpra server version 0.9.5
/bin/sh: 1: pulseaudio: not found
2013-06-09 04:16:55,064 xpra is ready.
2013-06-09 04:16:56,751 Warning: pulseaudio has terminated. Either fix the pulseaudio command line or use --no-pulseaudio to avoid this warning.
2013-06-09 04:16:57,678 child '/etc/X11/Xsession true' with pid 4000 has terminated
2013-06-09 04:18:32,471 New connection received: SocketConnection(/home/lindi/.xpra/sauna-7)
2013-06-09 04:18:33,489 Handshake complete; enabling connection
2013-06-09 04:18:33,507 Python/Gtk2 Linux client version 0.9.5 connected from 'sauna'
2013-06-09 04:18:33,508 mmap is enabled using 128MB area in /tmp/xpra.E7LJzn.mmap
2013-06-09 04:18:33,508 max client resolution is 1680x1050 (from [[1680, 1050]]), current server resolution is 5120x3200
2013-06-09 04:18:33,512 new resolution matching 1680x1050 : screen now set to 1680x1050
2013-06-09 04:18:33,514 setting key repeat rate from client: 500ms delay / 33ms interval
2013-06-09 04:18:33,517 setting keymap: rules=evdev, model=pc105, layout=fi
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
2013-06-09 04:18:33,595 setting keymap options: grp:alts_toggle
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "PC_RALT_LEVEL2" has 2 levels, but <LALT> has 3 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
2013-06-09 04:18:33,665 setting full keymap definition from client via xkbcomp
2013-06-09 04:18:33,893 sending updated screen size to clients: 1680x1050 (max 5120x3200)
2013-06-09 04:19:26,411 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1674x964
2013-06-09 04:19:26,546 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1674x964
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 452, in composite_configure_event
    self.read_geometry(True)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 368, in read_geometry
    trap.call_unsynced(synced_update)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 117, in call_unsynced
    return self._call(False, fun, args, kwargs)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 112, in _call
    raise e
TypeError: Don't know how to get a display from 16785535L
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 452, in composite_configure_event
    self.read_geometry(True)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 368, in read_geometry
    trap.call_unsynced(synced_update)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 117, in call_unsynced
    return self._call(False, fun, args, kwargs)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 112, in _call
    raise e
TypeError: Don't know how to get a display from 16785535L
2013-06-09 04:26:14,891 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1674x964
2013-06-09 04:26:14,901 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1674x964
2013-06-09 04:26:16,096 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:26:16,156 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:29:48,769 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:29:48,780 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:29:57,759 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:29:57,770 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:30:02,076 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:30:02,086 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:30:19,728 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:30:19,737 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:30:48,269 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:30:48,278 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:32:31,527 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:32:31,535 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:40:52,818 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:40:52,833 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:42:08,067 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:42:08,119 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 452, in composite_configure_event
    self.read_geometry(True)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 368, in read_geometry
    trap.call_unsynced(synced_update)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 117, in call_unsynced
    return self._call(False, fun, args, kwargs)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 112, in _call
    raise e
TypeError: Don't know how to get a display from 12594409L
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 452, in composite_configure_event
    self.read_geometry(True)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 368, in read_geometry
    trap.call_unsynced(synced_update)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 117, in call_unsynced
    return self._call(False, fun, args, kwargs)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 112, in _call
    raise e
TypeError: Don't know how to get a display from 12594409L
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 452, in composite_configure_event
    self.read_geometry(True)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 368, in read_geometry
    trap.call_unsynced(synced_update)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 117, in call_unsynced
    return self._call(False, fun, args, kwargs)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 112, in _call
    raise e
TypeError: Don't know how to get a display from 12594409L
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 452, in composite_configure_event
    self.read_geometry(True)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/window.py", line 368, in read_geometry
    trap.call_unsynced(synced_update)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 117, in call_unsynced
    return self._call(False, fun, args, kwargs)
  File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 112, in _call
    raise e
TypeError: Don't know how to get a display from 12594409L
2013-06-09 04:42:30,902 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:42:30,911 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:43:29,673 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962
2013-06-09 04:43:29,722 Uh-oh, our size doesn't fit window sizing constraints: 1680x975 vs 1678x962

Change History (5)

comment:1 Changed 8 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Timo Juhani Lindfors

damn, was caused by r3461 (a mistake backporting the code from trunk) - the codepath is not easy to hit, does r3608 fix things for you?

comment:2 Changed 8 years ago by Timo Juhani Lindfors

No time build from trunk now but I'll let you know once r3608 hits debian.

comment:3 Changed 8 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

0.10 is still far away, closing - feel free to re-open.

comment:4 Changed 8 years ago by Timo Juhani Lindfors

If the issue is closed there's a really high risk that it gets completely forgotten...

comment:5 Changed 8 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/355

Note: See TracTickets for help on using tickets.