Xpra: Ticket #497: Xpra-Launcher not starting (Code 255), xpra_cmd.exe works.

System: Windows 8.1 no special configuration (ie Windows Firewall, Windows Defender and Drivers) Lenovo Touch U430

I have nothing else to report as I tried to add the debugger but only got info that the process does exit with exit code 255. This problem seems to be there on all versions I tested from https://www.xpra.org/dists/windows/

What is going on? What else should I do? Is there a debugging binary I can try to use?

Wed, 15 Jan 2014 15:10:15 GMT - Antoine Martin: owner, status changed

Confirmed, you can help us by figuring out when this regression occurred, it certainly used to work before. This only affects Vista onwards, and is probably related to file write access somewhere.

Wed, 15 Jan 2014 15:25:49 GMT - Antoine Martin:

Note to drag0on: you can't have tried that many versions, I went far back based on the assumption that you had:

So the problem appeared between in the 0.10.x branch between r4669 and r4827 (not many changesets in that branch)

Wed, 15 Jan 2014 16:26:41 GMT - Antoine Martin: status changed; resolution set


This is yet another bug caused by FreeBSD compatibility (see #420). The fix is in r5196 for trunk and r5199 for v0.10.x branch.

I have rebuilt 0.10.12 with this patch on top and uploaded it: http://xpra.org/dists/windows/Xpra_Setup_0.10.12-r5199.exe

Closing - let me know if you still have problems.

Thu, 16 Jan 2014 21:36:25 GMT - drag0on:

Wow I was pretty sure that I tried Xpra_Setup_0.10.0-r4168.exe as it is in my Downloads folder, but after trying again you are right and this version is working. The given installer (Xpra_Setup_0.10.12-r5199.exe) is also working fine, thank you

Sat, 23 Jan 2021 04:57:24 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/497