Xpra: Ticket #724: System tray not able to change options with mix of left and right clicks

I can not change any option from the xpra tray. Tried to change Encoding, Quality,Speed, Speaker, Microphone, Keyboard. Only "Keyboards Synchronization" can be changed. May be related to submenus?

I had this behavior for many versions (I guess since the 0.12.x), but I blamed my old ubuntu installation. After updating to newer Ubuntu the issue persists.

Server: Ubuntu 14.04 with Xpra 0.14.10 Client: Windows 7 with Xpra 0.14.10

Sat, 01 Nov 2014 03:28:35 GMT - Antoine Martin: owner changed

If you right click on the tray to get the menu, you have to right click on the options. (same for left click) Apart from that, there are no known issues with the tray menu. I doubt that the server version could influence that.

Does this happen with all sessions? Even with just an xterm as application?

Is this a regression? Did not occur with versions older than 0.12.x? If so, can you download older version to pinpoint when the problem started?

Mon, 03 Nov 2014 12:17:59 GMT - rikky:

You are right. I tend to right click on tray icons, but It never occured to me to right click on a menu item.

Since I could not find an existing bug report for this behavior, I would like to keep this one open. Would be nice to not close the menu when clicking with the wrong button, or even better always react on left click.

Mon, 03 Nov 2014 14:11:36 GMT - Antoine Martin: summary changed

I believe I have just come up with a quick fix for this bug. Can you please test it for me? Then I can commit and backport it. There is a beta windows build (named r8044M)

Mon, 03 Nov 2014 14:12:01 GMT - Antoine Martin: attachment set

proposed fix

Tue, 04 Nov 2014 11:53:15 GMT - rikky:

The beta build did not fix the issue. The options don´t change when left clicking on a menu item after opening the tray menu with a right click. But there is an additional issue. After opening the menu with a right click and clicking on an option with a right click, the old option is not removed and you see multiple active options.

Tue, 04 Nov 2014 14:31:03 GMT - Antoine Martin:

Wait, I've just tried again and I am unable to reproduce the bug, even with older builds. What am I missing? Can you give us a more detailed, step by step reproduction? I've tried left then right, right then left, no difference, both work, even with older versions. Tested with XP and Windows 7 Ultimate 64-bit.

Thu, 06 Nov 2014 15:20:42 GMT - rikky:

Ok I´ll try:

  1. right click on the Xpra tray icon
  2. Move the mouse over "Encoding", to open that sub menu (I did not click it)
  3. left click on JPEG

The menu will close. But if you open the menu again, the old encoding is still active and not JPEG.

Thu, 06 Nov 2014 15:22:38 GMT - Antoine Martin: owner, status changed

Right, my bad. It's only (edited) radio checkboxes. Let me see what I can do.

Fri, 07 Nov 2014 03:34:21 GMT - Antoine Martin: owner, status, summary changed

The proposed fix was almost right, but not quite. Once I knew how to reproduce, it was a bit easier to figure out: r8064 fixes this. Will backport.

I've also edited the bug title to remove "windows" because this also affected other platforms - it was just a bit harder to hit.

@rikki: new beta build 8064 does that fix things for you?

Mon, 10 Nov 2014 08:18:56 GMT - rikky: status changed; resolution set

r8064 works great. Thanks.

Fri, 14 Nov 2014 18:20:00 GMT - Antoine Martin:

Backport for v0.14.x was in r8074.

We also need r8113 to avoid breaking the gtk3 port.. (backported in r8116)

Tue, 14 Apr 2015 18:04:55 GMT - Antoine Martin: priority, status changed; resolution deleted

Re-opening: I am seeing some problems with this code, both with the speed / quality sub menus and with the callbacks firing multiple times (blocking ticket:808#comment:8).

Tue, 14 Apr 2015 18:30:29 GMT - Antoine Martin: owner, status changed

This is fixed (again - but properly this time?) in r9002.

Needs backporting so keeping this ticket open.

Wed, 15 Apr 2015 06:47:18 GMT - Antoine Martin: status changed; resolution set

Backport in r9002. Works fine so closing. Feel free to re-open if I've missed something.

Mon, 18 May 2015 13:26:20 GMT - Antoine Martin:

FYI: this caused a bug somewhere else on win32: #864.

Mon, 18 May 2015 15:05:38 GMT - Antoine Martin:

r9442 changes the code so we only ever enable the workaround on win32 (trunk 0.16 only)

Sun, 19 Aug 2018 13:35:24 GMT - Antoine Martin:

The problem may have reappeared: #1907

Sat, 23 Jan 2021 05:04:06 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/724