Xpra: Ticket #725: Wrong and strange size for plots in Matlab


I usually connect from my MacPro? Retina to a Linux server through xpra. I run and use Matlab remotely using this service. Everything is fine in using Matlab, but a big problem I am having with plots in Matlab. Every time I plot something in Matlab, the plot's window is shown in a very strange resolution and size. It seems that Matlab (running on the server side) assumes some wrong screen size when opening a window for the plot. The problem happens always and it doesn't depend to the type of the plot. It is giving me a big headache. I appreciate if someone could help me on this. I have a screenshot of the situation which might be helpful:

smaller screenshot we can inline


Sat, 01 Nov 2014 03:22:46 GMT - hd_ali: attachment set

Screenshot: look to the plot appearance problem (strange size)

Sat, 01 Nov 2014 03:25:25 GMT - Antoine Martin: owner changed

Please provide more info: xpra info, server distro and version, etc.. Is libfakeXinerama installed? etc..

Sat, 01 Nov 2014 03:36:55 GMT - hd_ali:

Thanks for your reply.

The server information is:

Linux 2.6.32-431.29.2.el6.x86_64 #1 SMP Tue Sep 9 21:36:05 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
LSB Version:	:base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID:	CentOS
Description:	CentOS release 6.5 (Final)
Release:	6.5
Codename:	Final

And I searched for 'libfakeXinerama' on server and found it in following places:


Please let me know if you need more information.


Sat, 01 Nov 2014 03:42:55 GMT - Antoine Martin: attachment set

smaller screenshot we can inline

Sat, 01 Nov 2014 03:44:26 GMT - Antoine Martin: owner, status, description changed

This resize bug could be linked to #705, so you may want to subscribe to the CC list for that ticket.

Since I am unable to install matlab (there is no free version to use for testing), I am unable to test.. and unlikely to find the cause of the problem quickly. I may ask you to test a beta build if and when I make changes likely to impact this ticket.

Note: I have removed the dropbox links as those tend to go stale and added a smaller screenshot inline.

Sat, 01 Nov 2014 03:54:09 GMT - hd_ali:

OK, thank you very much for your quick replies. Hope to have the problem solved soon with your help.

Sat, 01 Nov 2014 18:46:00 GMT - Antoine Martin: owner, status changed

As per https://github.com/Xpra-org/xpra/issues/705#comment:8, are you running matlab with a Sun JDK version 6 or older? Can you try with a newer SDK as per How do I change the Java Virtual Machine (JVM) that MATLAB is using for Linux OS?

That may fix things. You can also try a new beta build with:

XPRA_NET_WM_NAME=Sawfish xpra start ...

Which should workaround the older buggy SDK.

Sun, 02 Nov 2014 04:18:35 GMT - hd_ali:

The java version in Matlab is:

Java 1.6.0_17-b04 with Sun Microsystems Inc. Java HotSpot(TM) 64-Bit Server VM mixed mode

So you suggest to update it?

Sun, 02 Nov 2014 04:21:40 GMT - Antoine Martin:

I see, you are using the buggy sun jdk. As per comment:5, your options are:

There is a good chance either one of those options will fix the bug.

Sun, 02 Nov 2014 04:37:49 GMT - hd_ali:

OK, Thanks for the options. I suppose both of the options need the server admin permission so I am going to ask him to pick one of the solutions and apply it. I will let you know the result.

Sun, 02 Nov 2014 04:42:01 GMT - Antoine Martin:

There are probably ways of installing the JDK in your home directory without requiring root access. As for xpra you can also install from source in your home directory. Neither of these options is very difficult, but not completely straightforward either.

Tue, 09 Dec 2014 03:48:43 GMT - Antoine Martin:

Can I close this ticket?

Fri, 26 Dec 2014 03:29:37 GMT - Antoine Martin: status changed; resolution set

Not heard back, closing. Feel free to re-open if you have more details.

Another update in this area was in #765, so you may have more luck with trunk builds.

Fri, 26 Dec 2014 03:39:32 GMT - Antoine Martin:

Received by email: The server admin upgraded the java jdk from 1.6 to 1.7 and the plot size problem has been solved. You may close this ticket. Thank you very much.

Sat, 23 Jan 2021 05:04:07 GMT - migration script:

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/725