xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 7 years ago

Last modified 5 months ago

#734 closed defect

xterm's empty cursor does not show on win32 — at Version 1

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 0.15
Component: platforms Version: trunk
Keywords: win32 Cc:

Description (last modified by Antoine Martin)

All the cursor tests seem to pass and look fine (custom cursor, all cursors) but the cursor used by xterm when you hit one of the modifier keys (at least for shift, control and alt) which is a completely empty one of size 6x13 (the size of one character on the default xterm) 9216 bytes of rgb data, shows up late (only shows when you move the mouse, at which point the xterm resets it) and it looks different from what it should be..

I managed to capture a screenshot of it by delaying the sending of cursors in ServerSource.send_cursor by 5 seconds, then hitting one of the special modifier keys, waiting 5 seconds, seeing the cursor log message on the client then moving the mouse and asking gimp to take a screen capture! Here it is:
screenshot of the funny cursor displayed on win32

I think this ticket is important because I have also seen crashes in the cursor code on win32 with the GTK3 port (#640).

Change History (2)

Changed 7 years ago by Antoine Martin

Attachment: win32-funny-cursor.png added

screenshot of the funny cursor displayed on win32

comment:1 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned
Note: See TracTickets for help on using tickets.