xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.

Opened 7 years ago

Closed 6 years ago

Last modified 8 months ago

#743 closed defect (fixed)

[Android Client] - "failed to negotiate a packet encoder" while trying to connect issue

Reported by: ben Owned by: ben
Priority: major Milestone: 0.15
Component: android Version: 0.11.x
Keywords: Cc:

Description (last modified by Antoine Martin)

When i try to connect to an Xpra Server with Android Client it displays a black screen during half a second then stops with an OK button dial "Xpra Client s'est arrêté" (="Xpra Client has stopped").

On ~/.xpra/:13.log :

2014-11-21 14:55:09,229 xpra is ready.
2014-11-21 14:56:35,318 New connection received: SocketConnection(('SERVER-IP', 14444) - ('CLIENT-IP', 60897))
2014-11-21 14:56:35,586 no matching packet encoder found!
2014-11-21 14:56:35,586 Disconnecting client Protocol(SocketConnection(('SERVER-IP', 14444) - ('CLIENT-IP', 60897))): protocol error (failed to negotiate a packet encoder)


  • Server OS Debian Wheezy
  • Xpra Server version: Xpra v0.14.1
  • Client OS: Android - Samsung Galaxy Tab 2
  • Xpra Client version: Xpra-0.11.0-r5216
  • Command line used on server: "xpra start --bind-tcp= :13"
  • Tried to play with --packet-encoders and --compressors (bencode, zlib ..) without success.
  • Works with the same server instance using Windows and Linux Xpra clients.

Attachments (1)

xpra-info (12.0 KB) - added by ben 7 years ago.
stdout of xpra info on server

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by ben

Attachment: xpra-info added

stdout of xpra info on server

comment:1 Changed 7 years ago by ben

Version: trunk0.14.x

comment:2 Changed 7 years ago by ben

Version: 0.14.x0.11.x

comment:3 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Milestone: 0.15
Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

It is quite possible that the Android client needs updating to run against newer servers, I haven't tried it in many many months.
The Android client is almost abandoned at this point unfortunately, I just don't have the time for everything.

comment:4 Changed 7 years ago by ben

Thanks for your feedback.

I'll try using an older Xpra server when i have time.

comment:5 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to ben
Status: assignednew

no matching packet encoder found!

Would normally mean that we miss bencode, but I see it in your xpra info...

I've uploaded an updated build (all but identical to the previous build, except for the version bump): http://xpra.org/beta/Android
Does that work for you? (works as good as before for me on 2 android devices)

comment:6 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Not heard back, I assume this works OK, moving it to replace the "old" one (it's labelled 0.15, but that doesn't really matter).

Feel free to re-open if you still have issues.

comment:7 Changed 8 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/743

Note: See TracTickets for help on using tickets.