xpra icon
Bug tracker and wiki

This bug tracker and wiki are being discontinued
please use https://github.com/Xpra-org/xpra instead.


Opened 7 years ago

Closed 7 years ago

Last modified 8 months ago

#819 closed defect (fixed)

win32 client does not exit cleanly (again)

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: critical Milestone: 0.15
Component: client Version: trunk
Keywords: win32 Cc:

Description

Some recent change to the event handling must have caused this.
We end up not cleaning up the tray and not running all the exit cleanup callbacks.
I have also seen a GTK warning about not being able to delete a window property..
Probably some time after r8546, before r8715.
Likely changeset: r8700.

Change History (2)

comment:1 Changed 7 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

r8700 was not the cause of the problem, so I looked into SetConsoleCtrlHandler
(and Registering a Control Handler Function) and implemented a solution which has the added benefit of working well with GTK3! (see #640)

I was wrong about the delete window property: this one is still there!

Version 1, edited 7 years ago by Antoine Martin (previous) (next) (diff)

comment:2 Changed 8 months ago by migration script

this ticket has been moved to: https://github.com/Xpra-org/xpra/issues/819

Note: See TracTickets for help on using tickets.